En poursuivant votre navigation sur ce site, vous acceptez l'utilisation de cookies pour vous proposer des contenus et services adaptés.
Mentions légales.
 
Texte à méditer :   Utilisateur de GuppY, je suis membre de l' Asso freeGuppY ... et vous ?   
Texte à méditer :   L'urgent est fait, l'impossible est en cours, pour les miracles prévoir un délai !   
Texte à méditer :   Je pense qu’il y a 3 mots sur le web en ce moment qui demandent du travail pour beaucoups d’entre nous : Responsive, Web, Design.   Ethan Marcotte
Texte à méditer :   Chaque site internet est un document vivant.   David Leuliette
Texte à méditer :   On se fait parfois surprendre. Par exemple, quand Internet est arrivé, c’était notre cinquième ou sixième priorité.   Bill Gates
Texte à méditer :   Il faut très certainement repenser Internet et les réseaux numériques de communication comme un véritable territoire à sécuriser.   Eric Freyssinet
Texte à méditer :   Aujourd'hui ce n'est pas possible de couper l'accès à internet. C'est quelque chose comme couper l'eau.    Fleur Pellerin
Texte à méditer :   Se connecter à internet, c’est y rencontrer des centaines de gens avec qui vous n’auriez jamais eu envie d’avoir quelque rapport que ce soit.   Dave Barry
Texte à méditer :   Un bon site Web est toujours “en construction” !   
Vous êtes ici :   Accueil » Forum » Plugin Annonces Plus » "Parse erreur" en cliquant sur Gestion des annonces en admin
    Imprimer la page...

Forum - Plugin Annonces Plus - "Parse erreur" en cliquant sur Gestion des annonces en admin


Connectés : ( personne )

le 28/09/2016 23:44
par Schmol44

Bonsoir Ludo,

Il m'arrive une drôle de truc, après avoir fait pas mal d'essais, je ne peux que te demander conseil.

Avant de "patcher guppy en V5.01.05", j'ai fait une dernière sauvegarde propre et voulant utiliser le "plugin Annonces plus", en me connectant en "admin", en cliquant sur "Gestion des annonces", j'obtiens l'erreur suivante :

"Parse error: syntax error, unexpected '[' in C:EasyPHP-5.3.9wwwMon_Site_V50102pluginsannoncesplusannoncesplus.php on line 147"

Je regarde dans le fichier incriminé et je ne vois rien d'anormal, je le recharge par FTP après m'être assuré que ça fonctionne en ligne, j'obtiens la même erreur.

Finalement, je le désinstalle et réinstalle proprement la dernière version, la V5.08, même erreur.

Je vérifie sur d'anciennes sauvegardes, Guppy V5.01.3, V5.01.02, même erreur.

Je reviens à ma sauvegarde de Guppy V5.01.4, je désinstalle complètement le plugin et le réinstalle par FTP depuis ma version en ligne qui fonctionne, même problème.

Par contre, j'arrive à installer la V5.04, ça fonctionne, si je la mets à jour avec n'importe laquelle des versions supérieures, j'ai le même problème.

Après plusieurs installations, désinstallations, voulant charger le fichier "zip", j'ai obtenu le message suivant  : Erreur : Extensions incorrecte !

Seul un fichier (*.inc) au format  d'inclusion PHP peut-être changé. k

J'ai eu ce message plusieurs fois, même en rafraîchissanr la page.

Là, j'avoue que je suis sec. n

D'avance merci pour ton aide..

Nota : En local je suis avec "EasyPHP 5.39"

Schmol44

  
Réponse n° 1
--------
le 29/09/2016 13:53
par lud80
Administrateur

Bonjour,
 
Citation :

en me connectant en "admin", en cliquant sur "Gestion des annonces", j'obtiens l'erreur suivante :
"Parse error: syntax error, unexpected '[' in C:\EasyPHP-5.3.9\www\Mon_Site_V50102\plugins\annoncesplus\annoncesplus.php on line 147"

Tu dis te connecter en admin et avoir une erreur sur annonces.php ligne 147 !!!
Pas possible, annonces.php est le script du plugin côté utilisateur.

Ligne 147, sur une version 5.0.8, il y a un ceci :
 
Code : php
$nbap = count($ptannonces);
Cela voudrait dire que la table des annonces n'existe pas. A mon avis la config du plugin est incomplète.

Ensuite tu testes d'anciennes versions, çà ne dit pas grand chose.

Ultime tentative, la ré-installation du plugin se solde par un échec Erreur : Extensions incorrecte !

Ce dernier problème ne vient assurément pas du plugin. Ta version de php en local est totalement obsolète.

J'ai testé en ligne la version 5.0.8 du plugin, sur un php 5.6.8, il fonctionne parfaitement. En local avec php 7.0.10, idem.

Je n'ai aucune solution à te proposer, sauf de faire évoluer ton php en local.

Amicalement, Lud. gyfree gyteam

  
Réponse n° 2
--------
le 29/09/2016 22:27
par Schmol44

Bonsoir Ludo,

Merci pour ta réponse.

En fait, hier soir, je ne devais plus voir clair, je me suis trompé en rédigeant ce post, il s'agissait de la ligne "139"et non 147. k

De toutes façons, tu as raison, je vais commencer par mettre à jour "Easy PHP", il y a longtemps que j'y pense, mais comme jusqu'ici je n'avais pas rencontré de problèmes avec, je remettais à plus tard.

Je suis en train de parcourir "le tutoriel de Config look" et ça m'occupe pas mal.

Quel superbe travail, tout y est, un grand BRAVO pour ça.

Je te tiendrais au courant.

D'abord ma skin,

Ensuite la V5.01.05 et après Easy Php dernière version.

A plus. k

Schmol44

  
Réponse n° 3
--------
le 30/09/2016 10:11
par Schmol44

Bonjour Ludo,

A propos, un chti bonjour à la Picardie, j'ai vécu à Amiens pendant 15 ans k

Bon, j'ai bien avancé sur mon problème, comme j'avais fait récemment une restauration sur mon PC, après avoir remplacé le disque dur, j'ai d'abord cru à un problème de PC et j'avoue avoir pensé à la version de php, mais sans plus. k

Hier soir, je me suis rappelé que j'avais une version plus récente de EasyPhp avec un php à la Version 5.4.14, j'ai fait l'essai, ça fonctionnait sans problème.

Je viens de télécharger la dernière version de "Easyphp," avec un php à la version 5.6.19, donc en local, je suis plus à jour qu'en ligne à la V5.6.8.

Le problème est donc réglé.

Merci. n

Schmol44

  
sujet actif   sujet clos   Important!   Nouveau  
Rectifier message   Clôturer sujet   Remonter sujet